Notiser

Sidan 1 av 2 12 SistaSista
Resultat 1 till 10 av 14
  1. #1 Unhappy Hur ser man vilken version av OSC som är installerad? 
    Reg.datum
    jun 2011
    Inlägg
    13
    Hej alla!
    Min son laddade ner OS Commerce för "ett tag sedan". Vi minns inte när, men filerna är från 2011-02-18 ser det ut som. Kan det varav3.0.1?

    Som jag skrivit tidigare hände något som gjorde att hela blocken med KATEGORIER och PRODUKTER försvann. Dessutom kan jag inte logga in på admin nu (på kons.sidan kan jag logga in). När jag försöker logga in på admin kommer följande text fram.

    OBS! Jag kan inte hitta någon fil som heter "languag.php".

    Så här ser indexsidan ut nu: http://www.hansa-electronic.com/nysi...alog/index.php

    Warning: require(includes/languages//nysida/catalog/includes/languag.php): failed to open stream: No such file or directory in /customers/6/c/0/hansa-electronic.com/httpd.www/nysida/catalog/admin/includes/application_top.php on line 167 Fatal error: require(): Failed opening required 'includes/languages//nysida/catalog/includes/languag.php' (include_path='.:/usr/share/php') in /customers/6/c/0/hansa-electronic.com/httpd.www/nysida/catalog/admin/includes/application_top.php on line 167

    Jag skulle vara väldigt tacksam om någon kan härleda mig till felet, så att jag kan fortsätta med shopen.

    Med vänliga hälsningar
    Hans
    Svara med citat  
    Oderland Webbhotell
    Oscforum.se rekommenderar Oderland vid drift av Webbutiker
    12 månaders backup och 24/7 teknisk support via telefon och chat ingår!

  2. #2 Standard  
    Reg.datum
    nov 2007
    Inlägg
    598
    Jag kan inte speciellt mycket om osCommerce, men om PHP och programmering kan jag precis allt.

    Versionen hittar du förmodligen i index.php, där kan du se kommentaren längst upp och antagligen se vilken build du kör.

    Angående:
    Kod:
    Warning: require(includes/languages//nysida/catalog/includes/languag.php): failed to open stream: No such file or directory in
     /customers/6/c/0/hansa-electronic.com/httpd.www/nysida/catalog/admin/includes/application_top.php on line 167 Fatal error: require(): 
    Failed opening required 'includes/languages//nysida/catalog/includes/languag.php' (include_path='.:/usr/share/php') in 
    /customers/6/c/0/hansa-electronic.com/httpd.www/nysida/catalog/admin/includes/application_top.php on line 167
    Så är det pga att ingen fil existerar i /customers/6/c/0/hansa-electronic.com/httpd.www/nysida/catalog/admin/includes/application_top.php. Antingen har du fel sökväg, eller finns inte filen.

    Dessutom
    Fatal error: require(): Failed opening required 'includes/languages//nysida/catalog/includes/languag.php

    Där ska du nog skriva "language.php" istället för att stava det fel!
    Svara med citat  

  3. #3 Standard  
    Reg.datum
    jun 2011
    Inlägg
    13
    Tack för ditt svar Robin! Nej - versionen står inte i indexfilerna. Och du säger att jag skall skriva language i 'includes/languages//nysida/catalog/includes/languag.php . Jag har aldrig skrivit i någon fil och jag kan inte hitta ordet languag någonstans!
    Jag är inte kapabel att förstå HUR det har kunnat ändras över huvud taget.

    Med vänlig hälsning
    Hans
    Svara med citat  

  4. #4 Standard  
    Reg.datum
    okt 2007
    Ort
    Cyprus
    Inlägg
    1 210
    Det verkar som att era includes/configure.php samt admin/includes/configure.php är felaktiga

    Om ni behöver hjälp så dra ett PM så kan jag fixa det åt er

    Citat Ursprungligen postat av hansa Visa inlägg
    Hej alla!
    Min son laddade ner OS Commerce för "ett tag sedan". Vi minns inte när, men filerna är från 2011-02-18 ser det ut som. Kan det varav3.0.1?

    Som jag skrivit tidigare hände något som gjorde att hela blocken med KATEGORIER och PRODUKTER försvann. Dessutom kan jag inte logga in på admin nu (på kons.sidan kan jag logga in). När jag försöker logga in på admin kommer följande text fram.

    OBS! Jag kan inte hitta någon fil som heter "languag.php".

    Så här ser indexsidan ut nu: http://www.hansa-electronic.com/nysi...alog/index.php

    Warning: require(includes/languages//nysida/catalog/includes/languag.php): failed to open stream: No such file or directory in /customers/6/c/0/hansa-electronic.com/httpd.www/nysida/catalog/admin/includes/application_top.php on line 167 Fatal error: require(): Failed opening required 'includes/languages//nysida/catalog/includes/languag.php' (include_path='.:/usr/share/php') in /customers/6/c/0/hansa-electronic.com/httpd.www/nysida/catalog/admin/includes/application_top.php on line 167

    Jag skulle vara väldigt tacksam om någon kan härleda mig till felet, så att jag kan fortsätta med shopen.

    Med vänliga hälsningar
    Hans
    Senast redigerad av tonyj den 2011-06-14 klockan 19:09.
    Svara med citat  

  5. #5 Standard  
    Reg.datum
    okt 2007
    Ort
    Cyprus
    Inlägg
    1 210
    Kolla i filen includes/configure.php efter dessa rader:
    define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
    define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

    kolla så att det verkligen står så som jag skrev nu

    samma sak gäller admin/includes/configure.php

    Citat Ursprungligen postat av hansa Visa inlägg
    Tack för ditt svar Robin! Nej - versionen står inte i indexfilerna. Och du säger att jag skall skriva language i 'includes/languages//nysida/catalog/includes/languag.php . Jag har aldrig skrivit i någon fil och jag kan inte hitta ordet languag någonstans!
    Jag är inte kapabel att förstå HUR det har kunnat ändras över huvud taget.

    Med vänlig hälsning
    Hans
    Svara med citat  

  6. #6 Standard  
    Reg.datum
    okt 2007
    Ort
    Cyprus
    Inlägg
    1 210
    Du har oscommerce v2.3.1

    Citat Ursprungligen postat av hansa Visa inlägg
    Tack för ditt svar Robin! Nej - versionen står inte i indexfilerna. Och du säger att jag skall skriva language i 'includes/languages//nysida/catalog/includes/languag.php . Jag har aldrig skrivit i någon fil och jag kan inte hitta ordet languag någonstans!
    Jag är inte kapabel att förstå HUR det har kunnat ändras över huvud taget.

    Med vänlig hälsning
    Hans
    Svara med citat  

  7. #7 Standard  
    Reg.datum
    jun 2011
    Inlägg
    13
    Citat Ursprungligen postat av tonyj Visa inlägg
    Kolla i filen includes/configure.php efter dessa rader:
    define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
    define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

    kolla så att det verkligen står så som jag skrev nu

    samma sak gäller admin/includes/configure.php
    Tack för info tonyj!

    I "KONS" finns de filerna mycket riktigt.
    Däremot i ADMIN heter filen "configuration.php" i stället!
    I den filen finns inte de raderna som du angett.
    Jag har antagligen bytt ut svenskafilerna i fel katalog och därmed kanske orsakat felet?!

    mvh Hans
    Senast redigerad av hansa den 2011-06-16 klockan 13:49.
    Svara med citat  

  8. #8 Standard  
    Reg.datum
    okt 2007
    Ort
    Cyprus
    Inlägg
    1 210
    nä då tittar du direkt under admin/configuration.php
    du ska kolla admin/includes/configure.php


    Citat Ursprungligen postat av hansa Visa inlägg
    Tack för info tonyj!

    I "KONS" finns de filerna mycket riktigt.
    Däremot i ADMIN heter filen "configuration.php" i stället!
    I den filen finns inte de raderna som du angett.
    Jag har antagligen bytt ut svenskafilerna i fel katalog och därmed kanske orsakat felet?!

    mvh Hans
    Svara med citat  

  9. #9 Standard  
    Reg.datum
    jun 2011
    Inlägg
    13
    Citat Ursprungligen postat av tonyj Visa inlägg
    nä då tittar du direkt under admin/configuration.php
    du ska kolla admin/includes/configure.php
    Ja då stämmer det. Men jag har fått mer problem. Jag bytte namn från "nysida/catalog/..." till "shop/catalog/...". Då fick jag problem med att byta ut en massa referenser från "nysida" till "shop" i så många filer jag kunde hitta fel i. Nu kan jag hitta alla "manufacturers" men inga kategorier och produkter, Men det räcker tydligen inte. Är det nu fel i databasen som ställer till det? Kan jag radikalt ominstallera hela shopen och ändå slippa att lägga in alla produkter som jag lagt ner en massa tid på? Jag har gjort en backup på hela shopen och kanske ligger produkterna där - eller finns de bara i databasen? Det börjar snurra i huvudet på mig av alla dessa problem som uppstått. Tacksam för tips på hur jag kan lösa detta.
    Svara med citat  

  10. #10 Standard  
    Reg.datum
    okt 2007
    Ort
    Cyprus
    Inlägg
    1 210
    om du ändrar mappen siten ligger i behöver du ENBART ändra configure.php filerna INGET ANNAT
    Problemet med kategorier/produkter etc är Språkrelaterat antagligen felaktigt language_id i databasen

    Produkterna finns bara i databasen förutom bilderna som ligger under mappen images

    Citat Ursprungligen postat av hansa Visa inlägg
    Ja då stämmer det. Men jag har fått mer problem. Jag bytte namn från "nysida/catalog/..." till "shop/catalog/...". Då fick jag problem med att byta ut en massa referenser från "nysida" till "shop" i så många filer jag kunde hitta fel i. Nu kan jag hitta alla "manufacturers" men inga kategorier och produkter, Men det räcker tydligen inte. Är det nu fel i databasen som ställer till det? Kan jag radikalt ominstallera hela shopen och ändå slippa att lägga in alla produkter som jag lagt ner en massa tid på? Jag har gjort en backup på hela shopen och kanske ligger produkterna där - eller finns de bara i databasen? Det börjar snurra i huvudet på mig av alla dessa problem som uppstått. Tacksam för tips på hur jag kan lösa detta.
    Svara med citat  



Behörigheter för att posta
  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •