Notiser

Sidan 2 av 5 FörstaFörsta 1234 ... SistaSista
Resultat 11 till 20 av 50
  1. #11 Standard  
    Reg.datum
    aug 2011
    Inlägg
    6
    tjena jag är oxå ny i osc men jag fixar inte allt detta, använde prestashop innan men jag får säga att med PS fanns det fan så mycket mer spåråk support att få, jag har nu lagt in översättningen i /includes/languages men då dog min "catalog" sida helt och fucking hållet jag har jobbar i 24 timmar med dena jävla osc men känner att om jag inte får hjälp snart lägger jag ner allt.

    problemet löst, det va browser minnet, men kolla det när ni hållet på. förlåt för mitt utbrott
    Senast redigerad av woobie den 2011-08-19 klockan 10:00. Anledning: löste problemet
    Svara med citat  
    Oderland Webbhotell
    Oscforum.se rekommenderar Oderland vid drift av Webbutiker
    12 månaders backup och 24/7 teknisk support via telefon och chat ingår!

  2. #12 Standard  
    Reg.datum
    jul 2007
    Inlägg
    7
    1. Hur får jag Svenskt språk som default? Jag har sortorder = 0 på svenska och provat sortorder 1-3 på engelskan. De har motsvarande id i databasen. Men varje gång jag går till /catalog eller /catalog/index.php så är det på engelska. Trots rensat cache och cockies. Sedan när jag växlar till svenska så är det på svenska. Men i browsern står det /catalog/index.php?language=sw Jag vill ju att det ska vara på svenska direkt när man kommer till index.php ? Och typ /catalog/index.php?language=en när man växlar till Engelska.
    2. Sedan får jag inte Tims UTF-8 Dual support att funka Blir helt blank sida i checkout_process ? sparade om checkout_process.php och checkout:success.php till Ansi men då blir det problem med å ä ö . Måste man in och skriva ä i koden?
    Svara med citat  

  3. #13 Standard  
    Reg.datum
    okt 2007
    Ort
    Cyprus
    Inlägg
    1 210
    antagligen använder du firefox. du måste ändra i includes/application_top.php så get_languages inte går efter browsern utan att den går efter default från admin

    när det gäller UTF-8 med TIMS ska du ändra databasen till latin1, antagligen använder du UTF8
    Alla språkfiler ska vara ansi

    Citat Ursprungligen postat av zero Visa inlägg
    1. Hur får jag Svenskt språk som default? Jag har sortorder = 0 på svenska och provat sortorder 1-3 på engelskan. De har motsvarande id i databasen. Men varje gång jag går till /catalog eller /catalog/index.php så är det på engelska. Trots rensat cache och cockies. Sedan när jag växlar till svenska så är det på svenska. Men i browsern står det /catalog/index.php?language=sw Jag vill ju att det ska vara på svenska direkt när man kommer till index.php ? Och typ /catalog/index.php?language=en när man växlar till Engelska.
    2. Sedan får jag inte Tims UTF-8 Dual support att funka Blir helt blank sida i checkout_process ? sparade om checkout_process.php och checkout:success.php till Ansi men då blir det problem med å ä ö . Måste man in och skriva ä i koden?
    Svara med citat  

  4. #14 Standard  
    Reg.datum
    jul 2007
    Inlägg
    7
    Citat Ursprungligen postat av tonyj Visa inlägg
    antagligen använder du firefox. du måste ändra i includes/application_top.php så get_languages inte går efter browsern utan att den går efter default från admin

    när det gäller UTF-8 med TIMS ska du ändra databasen till latin1, antagligen använder du UTF8
    Alla språkfiler ska vara ansi
    Tack för snabbt svar! Ja jag använder Firefox men samma i Chrome. Jag hittar get_languages i application_top men hur ändrar jag så att den går efter default från admin? Kan du visa med kodexempel tack!
    Svara med citat  

  5. #15 Standard  
    Reg.datum
    okt 2007
    Ort
    Cyprus
    Inlägg
    1 210
    Hitta detta:
    if (isset($HTTP_GET_VARS['language']) && tep_not_null($HTTP_GET_VARS['language'])) {
    $lng->set_language($HTTP_GET_VARS['language']);
    } else {
    $lng->get_browser_language();
    }


    Ändra till:
    if (isset($HTTP_GET_VARS['language']) && tep_not_null($HTTP_GET_VARS['language'])) {
    $lng->set_language($HTTP_GET_VARS['language']);
    } else {
    $lng->set_language('se');
    }

    PS.
    $lng->set_language('se');
    "se" är alltså koden för svenska om du tittar i admin så kan du eventuellt ha sw eller sv så kolla under språkinstallationerna i admin

    Hojta om det ändå inte fungerar

    Citat Ursprungligen postat av zero Visa inlägg
    Tack för snabbt svar! Ja jag använder Firefox men samma i Chrome. Jag hittar get_languages i application_top men hur ändrar jag så att den går efter default från admin? Kan du visa med kodexempel tack!
    Svara med citat  

  6. #16 Standard  
    Reg.datum
    aug 2011
    Inlägg
    6
    Citat Ursprungligen postat av tonyj Visa inlägg
    Hitta detta:
    if (isset($HTTP_GET_VARS['language']) && tep_not_null($HTTP_GET_VARS['language'])) {
    $lng->set_language($HTTP_GET_VARS['language']);
    } else {
    $lng->get_browser_language();
    }


    Ändra till:
    if (isset($HTTP_GET_VARS['language']) && tep_not_null($HTTP_GET_VARS['language'])) {
    $lng->set_language($HTTP_GET_VARS['language']);
    } else {
    $lng->set_language('se');
    }

    PS.
    $lng->set_language('se');
    "se" är alltså koden för svenska om du tittar i admin så kan du eventuellt ha sw eller sv så kolla under språkinstallationerna i admin

    Hojta om det ändå inte fungerar
    detta funkade inte allt jag får fortfarande upp sidan på eng och det språket finns inte ens på servern... men iaf jag använder chrome och sidan heter Ozone.se
    Svara med citat  

  7. #17 Standard  
    Reg.datum
    okt 2007
    Ort
    Cyprus
    Inlägg
    1 210
    Skicka PM så kan jag kika på det åt dig

    Citat Ursprungligen postat av woobie Visa inlägg
    detta funkade inte allt jag får fortfarande upp sidan på eng och det språket finns inte ens på servern... men iaf jag använder chrome och sidan heter Ozone.se
    Svara med citat  

  8. #18 Standard  
    Reg.datum
    jul 2007
    Inlägg
    7
    Citat Ursprungligen postat av tonyj Visa inlägg
    när det gäller UTF-8 med TIMS ska du ändra databasen till latin1, antagligen använder du UTF8
    Alla språkfiler ska vara ansi
    Ska databasen vara latin1 bin eller latin1_swedish_ci ?

    Jag ändrade alla filer i includes/languages/swedish till Ansi. Är det rätt?
    Och har lagt in [TiM's osC Solutions] ISO-8859-1 & UTF-8 Dual support men får det inte att fungera.

    Om jag inte har filerna som ansi får jag blank sida när jag klickar i kassan dvs checkout_process.php eller create-account.php osv.
    Men då funkar inte å,ä,ö
    Hur gör man? Måste man in i koden och skriva ä och ö eller?
    Svara med citat  

  9. #19 Standard  
    Reg.datum
    okt 2007
    Ort
    Cyprus
    Inlägg
    1 210
    alla språkfiler ska vara ansi inkl under mappar såsom modules osv både i admin och includes ( även huvud språkfilen swedish.php och där ska detta också vara:
    // charset for web pages and emails
    define('CHARSET', 'utf-8');

    )
    när det gäller latin1 så använder jag detta när jag kör sql i databasen
    DEFAULT CHARSET=latin1

    jag brukar exportera ut databasen och sök ändra och sedan köra in sql satsen igen så ändras hela direkt samt inför framtida inkörningar ( men man kan säkert ändra allt direkt men har inte testat utan jag kör så jag vet att allt är ok )
    Citat Ursprungligen postat av zero Visa inlägg
    Ska databasen vara latin1 bin eller latin1_swedish_ci ?

    Jag ändrade alla filer i includes/languages/swedish till Ansi. Är det rätt?
    Och har lagt in [TiM's osC Solutions] ISO-8859-1 & UTF-8 Dual support men får det inte att fungera.

    Om jag inte har filerna som ansi får jag blank sida när jag klickar i kassan dvs checkout_process.php eller create-account.php osv.
    Men då funkar inte å,ä,ö
    Hur gör man? Måste man in i koden och skriva ä och ö eller?
    Svara med citat  

  10. #20 Standard  
    Reg.datum
    okt 2007
    Ort
    Cyprus
    Inlägg
    1 210
    Nej du behöver inte använda ä och ö
    Citat Ursprungligen postat av zero Visa inlägg
    Ska databasen vara latin1 bin eller latin1_swedish_ci ?

    Jag ändrade alla filer i includes/languages/swedish till Ansi. Är det rätt?
    Och har lagt in [TiM's osC Solutions] ISO-8859-1 & UTF-8 Dual support men får det inte att fungera.

    Om jag inte har filerna som ansi får jag blank sida när jag klickar i kassan dvs checkout_process.php eller create-account.php osv.
    Men då funkar inte å,ä,ö
    Hur gör man? Måste man in i koden och skriva ä och ö eller?
    Svara med citat  



Behörigheter för att posta
  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •